3D Vision Blog

A normal user's look into the world of 3D Stereo Technologies

3D Vision Blog header image 2

15 Minutes Stereoscopic 3D GamePlay Video from Mafia 2 Demo

August 11th, 2010 · 19 Comments · Stereo 3D Games


Here is a short 15 minutes stereoscopic 3D video showing gameplay from the demo of the game Mafia 2, the game is running at maximum detail levels, with AA enabled and PhysX set to high, so you are seeing the best possible graphics quality, the video is in Side by Side format, recorded with FRAPS at 1680×1050 resolution. Leave your comments about the video below. Shorter stereoscopic 3D online video with Mafia 2 demo gameplay is also available on YouTube 3D.

Download the Mafia II Gameplay stereoscopic 3D Videomirror 1

Tags: ·······


19 responses so far ↓

  • 1 josh // Aug 11, 2010 at 07:05

    3d vision on my pc made mafia 2 look terrible, am i doing something wrong? i have gtx 480 and driver version 258.95. thanks for any help

  • 2 josh // Aug 11, 2010 at 07:47

    sorry meant to write i have driver 258.96

  • 3 Bloody // Aug 11, 2010 at 10:25

    Make sure you have the latest 3D Vision 1.33 CD beta drivers installed, not the ones included in the 1.33 WHQL release before that.

  • 4 chris // Aug 11, 2010 at 12:35

    i notice if i turn physx off and aa off my frame rate goes from 30 to 120 ( v-sync on ) the physx adds allot of nice smoke and dust effects and i cannot play it with aa of as it make the game so much crisper, guess i just need to buy a nice fast card to offload the physx too.

  • 5 Bloody // Aug 11, 2010 at 13:34

    You can try tweaking PhysX a bit with the tips published here: http://physxinfo.com/news/3628/mafia-ii-demo-tweaking-physx-performance/

  • 6 Druid // Aug 11, 2010 at 17:36

    Error: NVIDIA 3D Vision Video Player was not able to switch from fullscreen to windowed mode!
    Reason: Could not set video position!

    Any clue?

  • 7 Jox // Aug 11, 2010 at 19:52

    I got the same problem – all I get is a black screen – even have to end the player over the taskmanager.

    I suppose its a codec that I might be missing but hell if I knew which one.

    Already googled it but so far…no luck.

  • 8 Bloody // Aug 11, 2010 at 20:09

    Try installing the latest ffdshow, also check if you have it set in the player settings page for MPEG4 decoder…

  • 9 Jox // Aug 11, 2010 at 20:28

    no luck – installed the 3516rev of ffdshow and everything stays the same – black screen.

    When I uninstalled my old codecs I tried to open the file with my MediaPlayer (just to see if I’d get a picture at all): Had sound but no video.

    Now after installing the codec I once again have the black screen.

  • 10 Jox // Aug 11, 2010 at 20:58

    nm…must have been some old codec that didn’t get removed properly.

    Works great now – thanks

  • 11 PuzzON // Aug 11, 2010 at 22:24

    GTX 280 SLI + 9800GT PhysX dedicated will perform more than good??

  • 12 Helifax // Aug 12, 2010 at 00:45

    wow.. 3GPUs for 1 game? Hmm 4Gpus for 3d Vision Surround doesn’t seem to be that much then:))

  • 13 josh // Aug 12, 2010 at 01:33

    chris, not sure what video card(s) you have, but i have gtx 480, 8 gigs ram and an i5 processor, and phys-x kicked this demos ass on my computer, when i turned it off the framerate shot up. hopefully the final product is better optimized or gets drivers quickly. it seems mafia 2 demo and crysis are the only games that caused my computer any trouble when close to maxed out or maxed out.

  • 14 steve // Aug 12, 2010 at 19:09

    Looks good without the physx enhancements to be fair. Its annoying that they’ve locked convergence settings tho! :<

  • 15 Basementfilms // Aug 13, 2010 at 15:09

    Heya Bloody!

    Been a long time fan of yours… pretty much a daily visitor. Actually you kinda inspired my blog…

    anywho, been wondering what setup you used to run Mafia II. I currently have a i7 920, 6GB Ram, an Intel SSD and the GTX 470 playing with 3D Vision. With everything set to high (except the PhysX set to Med) I got ‘somewhat playable’ results.

    Is this expected with my setup? What should I improve?

  • 16 Bloody // Aug 13, 2010 at 15:31

    I’ve tried it with two GTS 480s in SLI and i5 750 CPU and I wasn’t very happy with the performance I got with everything on high, AA enabled, PhysX to high and in stereo 3D mode. I do hope that the final game will be much better optimized… they probably rushed the demo ;)

  • 17 Reventon // Aug 22, 2010 at 09:56

    I confount a problem like Jox. I’ve installed Win7codec and latest ffdshow, but still the same – black screen with sound. Potplayer can show the graph, but of course not in 3d mode. How can I set the codec correctly?

  • 18 Reventon // Aug 22, 2010 at 10:06

    I finally figure it out! I add “MPC – MP4 Splitter” in File->Settings->Decoder->Preferred Filters->MPEG4 Stream Spliter. Then the graph can be rendered correctly.

  • 19 shekhar // Jun 11, 2011 at 12:28

    braid-game.com

Leave a Comment